[Raw Msg Headers][Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

SIZE problem in headers: ZM 2.99.50-s5

Hi all,

I upgraded to ZMailer 2.99.50-s5 on Sparc Solaris 2.6 and i have noticed 
something odd in my syslog today, when <rnc@code.gob.pe> wanted to send
mail to some external email address ZMailer attached -literally- the "SIZE"
to the sender's email address, look:

Mar  4 10:20:05 zmailerserv router[1397]: S.qrVTz7607: from=<rnc@code.gob.pe>, rrelay=mxmailer.rcp.net.pe ([]:55025 "HELO mxmailer.rcp.net.pe" ident: "TIMEDOUT") size=80254, nrcpts=1, msgid=<m10IZny-00001aC@mxmailer.rcp.net.pe>
Mar  4 10:20:13 zmailerserv smtp[3622]: S.qrVTz7607: to=<ccr@corema.com.pe>, delay=00:00:14, xdelay=00:00:00, mailer=smtp, relay=BULK.RCP.NET.pe ([|25||42717]), stat=error2 <<- MAIL From:<rnc@code.gob.pe> SIZE=82615->> 550 '<rnc@code.gob.pe>SIZE=82615' sender address is not a valid domain. (this is abnormal, investigate!)

When i take a look at the smtpserver log i have this:

4092#   connection from mxmailer.rcp.net.pe ipcnt 1 ident: TIMEDOUT
4092w   220 zmailerserv.rcp.net.pe ZMailer Server 2.99.50-s5 #1 ESMTP+IDENT Thu, 4 Mar 1999 10:19:59 +0500
4092#   remote from []:55025
4092#   -- policyresult=0 initial policy msg: <NONE!>
4092r   HELO mxmailer.rcp.net.pe
4092w   250 zmailerserv.rcp.net.pe Hello mxmailer.rcp.net.pe
4092r   MAIL FROM:<rnc@code.gob.pe>
4093w   250 2.6.0 S.qrVTz7606 message accepted
4093#   S.qrVTz7606: 4146 bytes
4093r   QUIT
4093w   221 2.0.0 zmailerserv.rcp.net.pe Out
4092w   250 2.1.0 Sender syntax Ok
4092r   RCPT TO:<ccr@corema.com.pe>
4092w   250 2.1.5 Recipient address syntax Ok
4092r   DATA
4092w   354 Start mail input; end with <CRLF>.<CRLF>
4092w   250 2.6.0 S.qrVTz7607 message accepted
4092#   S.qrVTz7607: 80254 bytes
4092r   QUIT
4092w   221 2.0.0 zmailerserv.rcp.net.pe Out

Since the ZMailer smtpserver log shows that the server that initiated the 
connection did not provide the SIZE then ZMailer sent it by itself to the next
target server, which denied it like shows that server's logfile
(that is a Smail server):

03/04/1999 10:13:58: remote MAIL FROM: '<rnc@code.gob.pe>SIZE=82615' not a
valid domain; by zmailerserv.rcp.net.pe [].


	- Can this be a Smail bug instead?
	- Is this a documented BUG?
	- Is there some patch somewhere for this?
	- Should i recompile adding maybe one more space after MAIL FROM: <>?

This abnormal behaviour does not come up with every message, it's rather
unusual, anyhow it's pretty annoying..

Thanks a bunch,

 RCP - Internet Peru      Tel: +51 1 422-4848 
 Dpto de Operaciones      Fax: +51 1 421-8086